const regex = /([\[\]])[\s\n]+?(?=\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\[\\]])[\\s\\n]+?(?=\\1)', 'g')
const str = `{
"type": "Feature",
"properties": {
"id": 00001,
"poi": "cinemas",
"other": "null"
},
"geometry": {
"type": "MultiPoint",
"coordinates": [
[
7.0000000000000,
48.0000000000000
]
]
}
}
{
"type": "Feature",
"properties": {
"id": 00001,
"poi": "cinemas",
"other": "null"
},
"geometry": {
"type": "MultiPoint",
"coordinates": [
[
7.0000000000000,
48.0000000000000
]
]
}
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);