re = /^([a-z]*)\1+$/m
str = 'foofoofoo
foobar
barbar
abcdef
abcdefabcdefabcdefabcdef
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end