$re = '/[^\'":]*(("[^"]*"|\'[^\']*\')[^\'":]*)*/';
$str = 'foo:"01":"02":"03:04:05":"06:07:08:09"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);