package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0]?\d[:\.]\d\d`)
var str = `08:45
8:45
08.45
8.45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}