$re = '/find(?!\w*(?:by|with))\w+\(/mi';
$str = 'findBarByBuz()
findFoo()
findFooWithHo()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);