// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\sstyle=(?:"|')[^"']*(?:;?"|')"#).unwrap();
let string = "<span style=\"color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); display: inline !important; float: none;\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style='box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;'><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255)\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\"><span style=\"box-sizing: border-box; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255);\">dasdasdas dsad</span><img src=\"http://site.work/upload/pravo-post/2017/02/14/2/363/53da8504ca02e6d539dc82d0cbf05d92.jpg\" data-filename=\"FuoQn3L3x7s.jpg\" style=\"box-sizing: border-box; border: 0px; vertical-align: middle; color: rgb(0, 0, 0); font-family: Scada, sans-serif; font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(245, 245, 245); width: 397px;\">";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}