# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?:\/\/)?([а-я0-9_-]{1,32}|[a-z0-9_-]{1,32})\.([а-я0-9_-]{1,8}|[a-z0-9_-]\S{1,8})$"
test_str = ("/********************** yes *****************/\n"
"http://yandex.ru\n"
"http://asdasd.ru\n"
"sdfsdf.ru\n"
"http://sdfsdf.ru/sadasds-sadsad/sadsad\n"
"http://sdfsdf.ru/sadasds-sadsad/sadsad?page=2\n"
"http://sdfsdf.ru/sadasds-sadsad/sadsad?page=2&other=1\n"
"sdfsdf.ru/sadasds-sadsad/sadsad?page=2&other=1\n"
"http://sdfsdf.ru/sadasds/sadsad?page=2&other=1\n"
"https://regex101.com/r/tM7Pmr/1\n"
"http://regexpres.narod.ru/calculator.html\n"
"http://regexpres.narod.ru/calculator.htm\n"
"http://regexpres.narod.ru/calculator.php\n"
"http://regexpres.narod.ru/index.php\n"
"http://regexpres.narod.ru/index\n"
"https://jsfiddle.net/3b0khwhasd6/\n"
"https://lenta.ru/articles/2017/03/06/ruvlogs/\n"
"https://www.youtube.com/watch?v=PDxVcTWVIck\n"
"www.youtube.com/watch?v=PDxVcTWVIck\n\n"
"https://zakon.ru/blog/2017/03/06/delo_o_denezhnyh_generatorah_i_udobnom_sude__p-v_protiv_ikea_opredelenie_skgd_vs_ot_17012017_36-kg16\n"
"https://zakon.ru/konstitucionnyj_sud_rf\n\n"
"zakon.ru/blog/2017/03/06/delo_o_denezhnyh_generatorah_i_udobnom_sude__p-v_protiv_ikea_opredelenie_skgd_vs_ot_17012017_36-kg16\n"
"https://zakon.ru/konstitucionnyj_sud_rf\n\n\n"
"/********************** not *****************/\n"
"4234czxc\n"
"sdfsdf\n"
"sdsad.rturturturt/fsdfsd@sd")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.