re = /\/([^\/]+?)\/[^\/]+?$/i
str = 'product-resource/monitor-arms/cutsheets/edge'
# Print the match result
str.match(re) do |match|
puts match.to_s
end