package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(id="(.*?)(\"))`)
var str = `<div class="sscs" id="hai" class="hello">this is div</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}