re = /(?<=, )[^,]+(?=, CL)/m
str = '"8 IN, Ball Valve, Trunnion, Gen manu, CL 900, BW, Body LTCS, Metal Seat, Gear Operated, Trim Alloy 825, Full Bore, NACE MR 0175/ISO 15156 -with extended pup-piece as pipe schedule. VBFW 91Z08"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end