$re = '/^(\d{7}|\d{10})$/m';
$str = '1234567
1234567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);