$re = '/^\s*([\w\s.]*)\s*$/m';
$str = ' gfgfgfgf
())_+
khjhj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);