import Foundation
let pattern = #"\"(\w+)\"\s:"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
{ "eventid" : "a35bcc79-2411-49b3-8f45-537fd46dab96" , "visitorid" : "014db7ee44bc0024bbbe6241eedc0606c003f06400bd0" , "eventtime" : 1434594187000 , "useragent" : "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36" , "pageurl_full_url" : "https://store.trendmicro-europe.com/store" , "pageurl_query_params_env" : "BASE" , "pageurl_query_params_id" : "ThankYouPage" , "pageurl_query_params_action" : "DisplayPage" , "pageurl_query_params_reqid" : "13233624029" , "pageurl_query_params_locale" : "de_DE" , "pageurl_query_params_siteid" : "tmemea" , "pageurl_querystring" : "id=ThankYouPage&Env=BASE&Action=DisplayPage&reqID=13233624029&Locale=de_DE&SiteID=tmemea" , "pageurl_scheme" : "https" , "pageurl_domain" : "store.trendmicro-europe.com" , "pageurl_path" : "/store" , "referrerurl_full_url" : "https://store.trendmicro-europe.com/store?Action=DisplayPage&Env=BASE&Locale=de_DE&SiteID=tmemea&id=ThankYouPage&reqID=13233624029" , "referrerurl_query_params_action" : "DisplayPage" , "referrerurl_query_params_env" : "BASE" , "referrerurl_query_params_locale" : "de_DE" , "referrerurl_query_params_siteid" : "tmemea" , "referrerurl_query_params_id" : "ThankYouPage" , "referrerurl_query_params_reqid" : "13233624029" , "referrerurl_querystring" : "Action=DisplayPage&Env=BASE&Locale=de_DE&SiteID=tmemea&id=ThankYouPage&reqID=13233624029" , "referrerurl_scheme" : "https" , "referrerurl_domain" : "store.trendmicro-europe.com" , "referrerurl_path" : "/store" , "dom_title" : "Trend Micro Online-Shop - Bestellung abgeschlossen" , "dom_viewport_width" : "1920" , "dom_viewport_height" : "993" , "udo_internal_product_category" : "[ \"SEC\"]" , "udo_channel_closer" : "Other" , "udo_product_id" : "[ \"206411300\"]" , "udo_customurl" : "/checkout/de_DE/order-completed" , "udo__corder" : "13233624029" , "udo_channel_originator_credit" : "0" , "udo_as_page_name" : "trend store : checkout : thank you page" , "udo__cquan" : "[ \"1\"]" , "udo_internal_products_array" : "[ \"SEC \" , \" MR \" , \" NFQ \" , \" 2YR \" , \" 1PC \" , \" AR Off\"]" , "udo__ctax" : "9.57" , "udo_vis_random" : "70618350058794024" , "udo_event_value" : "1" , "udo_channel_category_closer" : "other" , "udo_customer_email" : "hagensturmwut@web.de" , "udo_ut_profile" : "main" , "udo_internal_renewal_type" : "[ \"AR Off\"]" , "udo__cprice" : "[ \"50.35\"]" , "udo_as_product_name" : "[ \"Trend Micro Internet Security\"]" , "udo_vis_perm_id_2" : "014db7ee44bc0024bbbe6241eedc0606c003f06400bd0" , "udo__ccurrency" : "EUR" , "udo__csku" : "[ \"TI-CIWW-M8X\"]" , "udo_referrer_eq_domain" : "false" , "udo_internal_customer_journey" : "[ \"\"]" , "udo__ccustid" : "435297354602" , "udo_as_page_type" : "checkout" , "udo_product_category" : "[ \"All Products\"]" , "udo_site_currency" : "EUR" , "udo_vis_session_id_2" : "1434593949895" , "udo_as_page_site_name" : "trend store" , "udo_channel_closer_credit" : "0" , "udo__cprod" : "[ \"206411300\"]" , "udo_event_category" : "E-Commerce" , "udo_order_shipping" : "0.00" , "udo_product_quantity_total" : "1" , "udo_order_payment_type" : "PayPal" , "udo__csubtotal" : "50.35" , "udo_ut_env" : "prod" , "udo__cship" : "0.00" , "udo__t_session_id" : "1434593949895" , "udo_channel_path" : "Other" , "udo__cpdisc" : "[ \"\"]" , "udo__cprodname" : "[ \"Trend Micro Internet Security\"]" , "udo__t_visitor_id" : "014e047678c7001938f5bd7dcd6d0606d00a006500bd0" , "udo_page_type" : "checkout" , "udo_customer_id" : "435297354602" , "udo_as_product_consumer_vs_business" : "[ \"consumer\"]" , "udo_channel_category_influencer" : "other" , "udo_event_action" : "Order Confirmation" , "udo_site_region" : "DE" , "udo_order_subtotal" : "50.35" , "udo__ccat" : "[ \"All Products\"]" , "udo_internal_sub_channel_id" : "[ \"NFQ\"]" , "udo_product_list_price" : "[ \"79.90\"]" , "udo_order_total" : "59.92" , "udo_load_rule_google_universal_analytics" : "true" , "udo_internal_product_subscription_length" : "[ \"2YR\"]" , "udo_ut_event" : "view" , "udo_channel_category_path" : "other" , "udo__pathname1" : "store" , "udo_channel_influencer_credit" : "0" , "udo_load_rules_tags_to_fire" : "gua_UA-36872905-3,marketo" , "udo_page_name" : "ThankYouPage" , "udo_order_currency" : "EUR" , "udo__cbrand" : "[ ]" , "udo_ut_version" : "ut4.36.201506171459" , "u "gua_UA-36872905-3,marketo" , "udo_page_name" : "ThankYouPage" , "udo_order_currency" : "EUR" , "udo__cbrand" : "[ ]" , "udo_ut_version" : "ut4.36.201506171459" , "u
do_cross_vis_session_ids" : "available" , "udo_product_name" : "[ \"Trend Micro Internet Security\"]" , "udo_product_quantity" : "[ \"1\"]" , "udo_channel_influencer" : "Other" , "udo_ut_account" : "trendmicro" , "udo_order_id" : "13233624029" , "udo_tealium_visitor_id_override" : "014e047678c7001938f5bd7dcd6d0606d00a006500bd0" , "udo__ctotal" : "59.92" , "udo_order_tax" : "9.57" , "udo_product_unit_price" : "[ \"50.35\"]" , "udo_channel_originator" : "Other" , "udo_internal_number_of_devices" : "[ \"1PC\"]" , "udo_order_discount" : "0.00" , "udo_channel_category_originator" : "other" , "udo__ccat2" : "[ ]" , "udo_url_wo_qs" : "https://store.trendmicro-europe.com/store" , "udo_load_rule_audiencestream" : "true" , "udo_device_detailed" : "desktop" , "udo_ve_basket_html_generated" : "true" , "udo_category" : "[ \"Trend Micro Internet Security\"]" , "udo_product_sku" : "[ \"TI-CIWW-M8X\"]" , "udo_device" : "desktop" , "udo_internal_product_name" : "[ \"SEC | MR | NFQ | 2YR | 1PC | AR Off\"]" , "udo_internal_product_id" : "[ \"MR\"]" , "udo_product_discount" : "[ \"\"]" , "js_utag_cfg_path" : "//tags.tiqcdn.com/utag/trendmicro/main/prod/" , "js_datalayer" : "[ \"{ \\\"customURL\\\" : \\\"/checkout/de_DE/order-completed\\\"}\" , \"{ \\\"gtm.start\\\" : 1434594193626 , \\\"event\\\" : \\\"gtm.js\\\"}\" , \"{ \\\"event\\\" : \\\"sale\\\" , \\\"transactionId\\\" : \\\"13233624029\\\" , \\\"transactionAffiliation\\\" : \\\"tmemea\\\" , \\\"transactionTotal\\\" : 50.35 , \\\"transactionTax\\\" : 9.57 , \\\"transactionShipping\\\" : 0 , \\\"transactionCurrency\\\" : \\\"EUR\\\" , \\\"transactionProducts\\\" : [ { \\\"sku\\\" : \\\"206411300\\\" , \\\"name\\\" : \\\"SEC | MR | NFQ | 2YR | 1PC | AR Off\\\" , \\\"category\\\" : \\\"All Products\\\" , \\\"price\\\" : 50.35 , \\\"quantity\\\" : 1}]}\" , \"{ \\\"event\\\" : \\\"gtm.dom\\\"}\"]" , "firstpartycookies_utag_main_dc_event" : "34" , "firstpartycookies_utag_main__ss" : "0" , "firstpartycookies_utag_main__st" : "1434595993661" , "firstpartycookies_utag_ulog__vi" : "014e0476791e005f54a93f2d05640606d00a006500bd0" , "firstpartycookies_utag_ulog__fs" : "1434593949982" , "firstpartycookies_utag_main_dc_visit" : "1" , "firstpartycookies_fcr" : "http://www.trendmicro.de/produkte/internet-sicherheitssoftware/index.html" , "firstpartycookies_optimizelyenduserid" : "oeu1434593947489r0.8301690202206373" , "firstpartycookies_fcp" : "C=0&T=1434593950386&DTO=1434593949534&U=1401563069&V=1434594127078" , "firstpartycookies_mbox" : "session#1434593944791-800726#1434596054|PC#1434593944791-800726#1497666194|check#true#1434594254" , "firstpartycookies_op_browser" : "safari_537.36" , "firstpartycookies__gat_tealium" : "1" , "firstpartycookies__gat_trend" : "1" , "firstpartycookies_op_browserhigh" : "safari" , "firstpartycookies_utag_main_ses_id" : "1434593949895" , "firstpartycookies__ga" : "GA1.2.505298797.1433309956" , "firstpartycookies_fcc" : "X=C1401563069&Y=1434594127083&FV=18&H=1434594127078&fcTHR=shop.digitalriver.com}www.trendmicro-europe.com,www.digitalriver.com}www.trendmicro-europe.com,store.digitalriver.com}www.trendmicro-europe.com,store.trendmicro-europe.com}www.trendmicro-europe.com&Z=3&vis=m14z1#s3#e504211zde_DE#s4#m14z2&E=220062&F=0&I=1434594152851" , "firstpartycookies_utag_main__sn" : "1" , "firstpartycookies_gc_ss_tmemea" : "19B4F75E4FEC9468A2E6AC258A4D5F1F07C358164CAB37A182BBD6FD4BC11C783EB8C3E5FE6E2CEC" , "firstpartycookies_utag_ulog__cs" : "1434593949982" , "firstpartycookies_trend_ecommerce_previousurl" : "store.trendmicro-europe.com/store?Action=DisplayPage&Env=BASE&Locale=de_DE&SiteID=tmemea&id=ThankYouPage&reqID=13233624029" , "firstpartycookies_visitor_id" : "971D4E8DFAED4367957BC5516507C190A4B4FF01327F780F" , "firstpartycookies_fcoos" : "fcOptOutChip=undefined" , "firstpartycookies_mmcore_srv" : "ldnvwcgus04" , "firstpartycookies_utag_ulog__ts" : "1434594193761" , "firstpartycookies_op_os" : "windows" , "firstpartycookies_mmcore_pd" : "-260045609|CgAAAAoBQo5qLK4SDC51it4BABwUz6WEd9JIDwAAAArc8xOEd9JIAAAAAP//////////ABF3d3cudHJlbmRtaWNyby5kZQMSDAEAAAAAAAAAAAAAM4IAAPB2AAAzggAAAQCqMwAAAFeiYjgSDAD/////ARIMEgz//wEAAAEAAAAAAZeDAADRzgAAAfB2AAABAAAAAAAAAUU=" , "firstpartycookies_utag_ulog__evc" : "9" , "firstpartycookies_channelflow" : "Other|other|1437186193989" , "firstpartycookies__mkto_trk" : "id:945-CXD-062&token:_mch-trendmicro-europe.com-1434593950434-55791" , "firstpartycookies_mm_orderid" : "13233624029" , "firstpartycookies_bigipserverp_gc2_prd_active_c020_m1" : "3979268106.260.0000" , "firstpartycookies_utag_main_v_id" : "014e047678c7001938f5bd7dcd6d0606d00a006500bd0" , "firstpartycookies_refurl" : "http://www.trendmicro.de/produkte/internet-sicherheitssoftware/index.html" , "firstpartycookies___utma" : "267052492.169290300.1434593950.1434593950.1434593950.1" , "firstpartycookies_fcpt" : "https://store.trendmicro-europe.com/DRHM/store" , "firstpartycookies___utmc" : "267052492" , "firstpartycookies_channeloriginator" : "Other" , "firstpartycookies___utmb" : "267052492.9.9.1434594128359" , "firstpartycookies_channelcloser" : "Other" , "firstpartycookies_utag_main__pn" : "5" , "firstpartycookies___utmz" : "267052492.1434593950.1.1.utmcsr=trendmicro.de|utmccn=(referral)|utmcmd=referral|utmcct=/produkte/internet-sicherheitssoftware/index.html" , "firstpartycookies___utmt" : "1" , "firstpartycookies_optimizelybuckets" : "{}" , "firstpartycookies_utag_ulog__sc" : "1" , "firstpartycookies_utag_ulog__ev" : "1" , "firstpartycookies_mmid" : "-1538482063|CgAAAAqOaiyuEgwAAA==" , "firstpartycookies_optimizelypendinglogevents" : "[\"n=https%3A%2F%2Fstore.trendmicro-europe.com%2Fstore%3FAction%3DDisplayPage%26Env%3DBASE%26Locale%3Dde_DE%26SiteID%3Dtmemea%26id%3DThankYouPage%26reqID%3D13233624029&u=oeu1434593947489r0.8301690202206373&wxhr=true&time=1434594193.487&f=2768980424,2971080012,2972670324,2977260584,2978640108,2979190277,2982862612,2996610471,2999320925,3002870234,3009590130,3010411532,3010490661,3012030325,3012290930,3013550107,3013760244,3015480251,3016230230,3016600354,3017680067,3018650199,3020070270,3021420266,3021900006,3022920263,3023490069,3023680079,3031860711,3035490758&g=2757770822,2786691329,2916450245\"]" , "firstpartycookies_tmemea_pgm" : "76176400" , "firstpartycookies_utag_ulog__ec" : "20" , "firstpartycookies_db_sampling_40" : "other" , "firstpartycookies_utag_ulog__vr" : "http://www.trendmicro.de/produkte/internet-sicherheitssoftware/index.html" , "firstpartycookies_mmcore_tst" : "0.143" , "firstpartycookies_optimizelysegments" : "{\"180328736\":\"gc\",\"180346625\":\"referral\",\"180346626\":\"false\",\"180356504\":\"none\",\"2368180888\":\"referral\",\"2368860567\":\"gc\",\"2386140173\":\"false\",\"2389240235\":\"none\"}"}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)