re = /@.+?([a-zA-Z0-9-\_]*)\.[a-zA-Z0-9\-\_]{2,4}$/
str = 'someone@something.dom-ain.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end