using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CUI: *\S+ +([A-Z]+)";
string input = @"CUI: RO39890982 BZ 347";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}