package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z_][\w.-]*$`)
var str = `NANam
NANam.Word
NANam-Word`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}