import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\b((?:Ñочетание|традиционных|журналиÑÑ‚Ñких|приемов|вÑем)(?:\W+(?:\w{0,3}\W+)*(?:Ñочетание|традиционных|журналиÑÑ‚Ñких|приемов|вÑем))*)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"<p>Ðналитики Марк СтÑнÑер, Билл ÐдÑйр, Ðарон Кролик и Прашант Камалакантан изучили, каких digital-инÑтрументов не хватает в Ñовременных СМИ и ньюзрумах. Результаты иÑÑÐ»ÐµÐ´Ð¾Ð²Ð°Ð½Ð¸Ñ Ð¾Ð½Ð¸ опубликовали под неоднозначным названием «<a href="http://www.goatmustbefed.com/">Козлов надо кормить</a>». Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð¦ÐŸ предÑтавлÑет Ñамые интереÑные тезиÑÑ‹ из Ñтого иÑÑледованиÑ.</p><div><p><a href="http://www.rtdna.org/article/newsroom_staffing_stagnates#.U1lBpMZUMZc">обнадеживающую ÑтатиÑтику</a> роÑта цифровых проÑмотров, ÑущеÑтвует Ñ€Ñд барьеров, которые Ñдерживают проникновение digital-инÑтрументов в Ñовременных Ñлужбы новоÑтей.</p><h2>Барьеры приоритетов</h2><p>Ðналитики отмечают, что по мнению главных редакторов СМИ и продюÑеров медиа-реÑурÑов, digital — Ñто дополнительные «ÑвиÑтелки», дополнÑющие традиционный формат подачи новоÑтей и не имеющие права на ÑущеÑтвование в качеÑтве отдельной формы.</p><p>Ðто приводит к тому, что команды digital-ÑпециалиÑтов занимаютÑÑ Â«Ñ€ÐµÐ¿Ñ€Ð¾Ð´ÑƒÐºÑ†Ð¸Ñми», а не Ñозданием оригинального контента. ВмеÑто иÑторий в интерактивном формате и качеÑтвенной инфографики как ÑамоÑтоÑтельного жанра они Ñоздают цифровые копии аналоговых новоÑтей. ÐффективноÑть такой «работы» Ñ digital-инÑтрументами невелика.</p><h2>Организационные барьеры</h2><p>У новоÑтников чаÑто не хватает техничеÑких навыков Ð´Ð»Ñ Ñ‚Ð¾Ð³Ð¾, чтобы ÑовмеÑтить производÑтво и раÑпроÑтранение контента Ñ Ð·Ð°Ð¿Ñ€Ð¾Ñами аудитории, рекламодателей и подпиÑчиков. ОÑобенно еÑли речь заходит о мобильных платформах, интерактивных Ñайтах и «Ñторителлинге».</p><p>СиÑтемы публикации, Ñ€ÐµÐ´Ð°ÐºÑ‚Ð¸Ñ€Ð¾Ð²Ð°Ð½Ð¸Ñ Ð¸ ÑовмеÑтного ÑÐ¾Ð·Ð´Ð°Ð½Ð¸Ñ ÐºÐ¾Ð½Ñ‚ÐµÐ½Ñ‚Ð° нуждаютÑÑ Ð² квалифицированной поддержке. Также надо учитывать рекламные метрики, показатели поÑещаемоÑти, оÑобенноÑти работы тех или иных движков и удобÑтво их иÑÐ¿Ð¾Ð»ÑŒÐ·Ð¾Ð²Ð°Ð½Ð¸Ñ Ð¶ÑƒÑ€Ð½Ð°Ð»Ð¸Ñтами и редакторами.</p><h2>Ð¡Ð¿Ñ€Ð¾Ñ Ð½Ð° журналиÑтику данных</h2><p>Один из главных приоритетов ÑÐµÐ¹Ñ‡Ð°Ñ Ð´Ð»Ñ Ð¡ÐœÐ˜ — журналиÑтика данных и Ñоздание интерактивных иÑторий. Инфографика, Ð¸Ð½Ñ‚ÐµÑ€Ð°ÐºÑ‚Ð¸Ð²Ð½Ð°Ñ Ñ…Ñ€Ð¾Ð½Ð¸ÐºÐ° и динамичеÑкие диаграммы ÑпоÑобны раÑÑказать о политичеÑких или ÑкономичеÑких ÑобытиÑÑ… намного больше, чем Ñкучный «Ñухой» текÑÑ‚ Ñ Ð¿Ð°Ñ€Ð¾Ð¹ Ñтатичных картинок.</p><p>Ð’Ð¸Ð·ÑƒÐ°Ð»Ð¸Ð·Ð°Ñ†Ð¸Ñ Ð¸Ñторий и Ñочетание традиционных обо журналиÑÑ‚Ñких приемов Ñ Ñ†Ð¸Ñ„Ñ€Ð¾Ð²Ñ‹Ð¼Ð¸ технологиÑми, взÑтыми у блогов и Ñоциальных Ñетей, — залог интереÑа пользовательÑкой аудитории и повторного Ð¿Ð¾Ñ‚Ñ€ÐµÐ±Ð»ÐµÐ½Ð¸Ñ Ð¾Ð´Ð½Ð¾Ð³Ð¾ и того же контента в течение длительного времени.</p><p>Именно поÑтому репортер, который ÑпоÑобен иÑпользовать инÑтрументы Ñ€ÐµÐ´Ð°ÐºÑ‚Ð¸Ñ€Ð¾Ð²Ð°Ð½Ð¸Ñ Ð¸ Ð¾Ñ„Ð¾Ñ€Ð¼Ð»ÐµÐ½Ð¸Ñ Ñ†Ð¸Ñ„Ñ€Ð¾Ð²Ð¾Ð³Ð¾ контента, ÑÐµÐ¹Ñ‡Ð°Ñ Ñ†ÐµÐ½Ð½ÐµÐµ, чем репортер Ñ Ð´Ð¸ÐºÑ‚Ð¾Ñ„Ð¾Ð½Ð¾Ð¼, который проÑто пишет текÑты без навыков иÑÐ¿Ð¾Ð»ÑŒÐ·Ð¾Ð²Ð°Ð½Ð¸Ñ digital.</p><h2>ИнÑтрументы, которые Ñтоит взÑть на вооружение</h2><p>Ð”Ð»Ñ Ð½Ð°Ñ‡Ð°Ð»Ð° работы Ñ digital аналитики рекомендуют новоÑтникам иÑпользовать Ñледующие инÑтрументы:</p><ul> <li><a href="http://www.google.com/get/mediatools/">Google Media Tools</a> — набор инÑтрументов Ð´Ð»Ñ Ð°Ð½Ð°Ð»Ð¸Ð·Ð° и ÑƒÐ¿Ñ€Ð°Ð²Ð»ÐµÐ½Ð¸Ñ Ð´Ð°Ð½Ð½Ñ‹Ð¼Ð¸, позволÑющий генерировать карты и графики на оÑнове маÑÑива Ñобранной информации;</li><li><a href="http://www.tableausoftware.com/public/">Tableau Public</a> — анализ данных и Ñоздание диаграмм и разных визуализаций, которые можно вÑтроить в любой Ñайт;</li><li><a href="http://quartz.github.io/Chartbuilder/">Chartbuilder</a> — Ð´Ð»Ñ Ð±Ñ‹Ñтрого поÑÑ‚Ñ€Ð¾ÐµÐ½Ð¸Ñ Ð³Ñ€Ð°Ñ„Ð¸ÐºÐ¾Ð²;</li><li><a href="http://www.documentcloud.org/">DocumentCloud</a> — Ð´Ð»Ñ Ð¿ÑƒÐ±Ð»Ð¸ÐºÐ°Ñ†Ð¸Ð¸ документов и примечаний к ним Ñ Ð²Ð¾Ð·Ð¼Ð¾Ð¶Ð½Ð¾Ñтью поделитьÑÑ Ð´Ð°Ð½Ð½Ñ‹Ð¼Ð¸ Ñ Ð°ÑƒÐ´Ð¸Ñ‚Ð¾Ñ€Ð¸ÐµÐ¹, размеÑтив ÑÑылку или вÑтроив документ прÑмо в текÑÑ‚ новоÑти;</li><li><a href="https://www.overviewproject.org/">The Overview Project</a> — инÑтрумент Ñочетание Ð´Ð»Ñ Ð¿Ñ€Ð¸ÐµÐ¼Ð¾Ð² категоризации маÑÑива документов, Ð²ÐºÐ»ÑŽÑ‡Ð°Ñ Ð²Ð¾Ð·Ð¼Ð¾Ð¶Ð½Ð¾Ñть импорта из DocumentCloud;</li><li><a href="http://tabula.nerdpower.org/">Tabula</a> — Ð´Ð»Ñ ÑƒÐ¿Ñ€Ð¾Ñ‰ÐµÐ½Ð¸Ñ Ð¿Ñ€Ð¾Ñ†ÐµÑÑа Ð¸Ð·Ð²Ð»ÐµÑ‡ÐµÐ½Ð¸Ñ Ð´Ð°Ð½Ð½Ñ‹Ñ… из PDF-файлов, которые подлежат анализу;</li><li><a href="http://pandaproject.net/">PANDA Project</a> — инÑтрумент Ð´Ð»Ñ ÑÐ¾Ð·Ð´Ð°Ð½Ð¸Ñ Ñ†Ð¸Ñ„Ñ€Ð¾Ð²Ð¾Ð¹ библиотеки Ð´Ð»Ñ Ð½ÑŒÑŽÐ·Ñ€ÑƒÐ¼Ð°, Ñ Ð¿Ð¾Ð¼Ð¾Ñ‰ÑŒÑŽ которого публикациÑми, файлами и выдержками из документов можно поделитьÑÑ ÑовÑеми журналиÑтами в команде;</li><li><a href="http://projects.knightlab.com/projects/TimelineJS">TimelineJS</a> — ÑпоÑоб Ñоздать интерактивную хронику, добавлÑемую на Ñайт новоÑтного реÑурÑа, телеканала или радиоÑтанции. ПозволÑет Ñобрать разные виды материалов из Ñоциальных медиа, ÑÑылки на публикации в микроблогах и видеоролики.</li></ul></div>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)