const regex = /(?<=[=,])\s*[A-Za-z2]+(?=\()(?![^']*'!)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[=,])\\s*[A-Za-z2]+(?=\\()(?![^\']*\'!)', 'g')
const str = `=VLOOKUP(\$A9,'Summary'!\$A\$10:\$C\$30,3,FALSE)
=IFERROR((C10/B10),"N/A")
=sum('New Chart =Data(Date)'!L70)
=IFERROR((C10/B10),Len(E30))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}