$re = '/$/';
$str = 'I am the best CSS validator that I know';
$subst = " of";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;