re = /\w{1}:\/\/([a-zA-Z0-9\-\_\s]+\/)*\w+\.\w+/m
str = 'c://program files/system32/data.dat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end