re = /(string)/i
str = 'clen=a.length;for(i=0;i<clen;i++)b+=String.fromCharCode(a.charCodeAt(i)^2)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end