package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^a{2}$`)
var str = `aa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}