package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\p{IsHan}\n?。,?!]+$`)
var str = `He is 45 today
你今天45岁了
这个句子没有数字
Ok I see`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}