re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])(?=(?:.*[\da-zA-Z]){3})\S{8,}$/
str = '1234Ddddddd$'
# Print the match result
str.match(re) do |match|
puts match.to_s
end