const regex = /(?<!flecha)(?<!flecha1)\.jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!flecha)(?<!flecha1)\\.jpg', 'g')
const str = `hola.jpg
flecha.jpg
flecha1.jpg
bla.jpg
thisonetoo.jpg
butnotthisone.jpeg
flecha1.jpg
flecha2.jpg
flecha3.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}