$re = '/<([^>]+)>(?![^A]*A[^A]*$)/';
$str = 'B <4>.<5> <6> A <1> m<2> . <3>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);