re = /^(25[0-5]|2[0-4]\d|[0-1]?\d?\d)(\.(25[0-5]|2[0-4]\d|[0-1]?\d?\d)){3}$/
str = '255.255.255.255'
# Print the match result
str.match(re) do |match|
puts match.to_s
end