$re = '/^(?:A()|B()|C()){3}\1\2\3$/m';
$str = 'ABC
CBA
BBC
AAA
BAC
BCC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);