// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}").unwrap();
let string = "{-#stepone#-}
<p>email</p>
<FORM method=\"POST\" action=\"register.php?act=2\">
<input type=\"text\" name=\"email\" placeholder=\"enter email\" value=\"\"></input>
<input type=\"submit\" value=\"submit\"></input>
</FORM>
{-#stepone#-}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}