$re = '/([\w.]+)\/((?:\d+|all))/';
$str = 'sitename.com/johe8.nsmith/2014
sitename.com/johnsmith/all';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);