$re = '/(?:^\K\w+.*+|\R{2}\K\w+.*+)/';
$str = 'Title1
- blabla
blabla
-Blalba
anew Title 2:
thrid Title3 blabla
blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);