$re = '/^(?!-)((?:[a-z0-9]+-?)+)(?<!-)$/m';
$str = '--bad-slug
-bad-slug
bad--slug
bad-slug-
bad-slug--
good
better-slug';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);