using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*"")(.*\/)(.*)("".*)";
string input = @"this is ,y block of text with a ""/path/to/some/file/file/test/me.txt"" thsssdfd";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}