import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([012][0-9])|(3[01]))\\/([0]{0,1}[1-9]|1[012])\\/\\d{4} ([01][0-9]|[2][0-3]):([01345][0-9])";
final String string = "30/09/1979 12:59";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}