#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9/<]){9}[0-9]([A-Za-z]){3}([0-9]){6}([0-9])([MmFf\<])([0-9])([0-9]){6}([a-zA-Z0-9/<]){14}([0-9]){2}"
Local $sString = "#Fictional MRT" & @CRLF & _
"L898902C<3UTO6908061F9406236ZE184226B<<<<<14" & @CRLF & _
"#Sample USA" & @CRLF & _
"3400072370USA6707046F1608078910000193<113538" & @CRLF & _
"#Sample JPN" & @CRLF & _
"XS12345673JPN7902206F1101018<<<<<<<<<<<<<<00" & @CRLF & _
"#Sample UK" & @CRLF & _
"4580059179GBR7310216M1602135<<<<<<<<<<<<<<06" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")