$re = '/\b\d+(?:\.\d+)*\b/';
$str = 'hello.1.2.3.4.world';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);