$re = '/(?ims)^"""(?:(?:[^"]|"(?!""))*?(xyz))?.*?^"""(?(1)|(*SKIP)(*F))/';
$str = '"""
blah blah
blah
xyz
blah blah
"""
"""
blah blah blah
blah
"""
# xyz
def foo(self):
"""
blah
"""
-----------------
no xyz no
"""
yes xyz yes
"""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);