import re
regex = re.compile(r"\"[^\"]*(\bdog\b)[^\"]*\"", flags=re.IGNORECASE)
test_str = "Dog sighed. \"I'm no super dog, nor special dog,\" said Dog, \"I'm an ordinary dog, now leave me alone!\" Dog pushed him away and made his way to the other dog."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")