import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^@([^\\s.]+)$";
final String string = "@php\n"
+ "@python\n"
+ "@stackoverflow.com\n"
+ "@google.com\n"
+ "@stackexchange.com\n"
+ "@perl\n"
+ "@regex\n"
+ "@google.com\n"
+ "@foo.com\n"
+ "@bar.com\n"
+ "@baz.com\n"
+ "@google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}