package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\d.\-]+`)
var str = `����\�p�a�t�r�i�c�k�-�t�e�s�t�-�f�i�l�e�.�t�x�t������x�SMB2`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}