const regex = new RegExp('\\d*((\\s)?(m²|m|M)) de bureaux?|bureaux? d\\'une surface de \\d*((\\s)?(m²|m|M))|bureaux? de \\d*((\\s)?(m²|m|M))', 'gm')
const str = `REGEX_1 =(avec|(partie|à usage|compos[ée]) de|(possibilit[eé]|zone|espace)(\\sde)?) bureaux?
REGEX_2 =\\d*((\\s)?(m²|m|M)) de bureaux?|bureaux? d'une surface de \\d*((\\s)?(m²|m|M))|bureaux? de \\d*((\\s)?(m²|m|M))
REGEX_3 =bureaux? (à l'[eé]tage|[ée]quip[ée]s?|cloisonn[ée]s)
REGEX_2NOT =
(proche de bureaux?|
bureaux? proche|
bureaux? [àa] proximit[eé]|
[àa] proximit[eé] de bureaux?)
[EXEMPLE]
avec bureau
à usage de bureaux
composé de bureau
d'activites & bureaux
activités/bureaux
une partie de bureau
et bureau
et de bureau
12m² de bureaux
de bureaux de 12m²
bureaux d'une surface de 12m²
bureaux à l'étage
bureaux équipés
zone bureau
bureaux cloisonnés
possibilité de bureau
espace bureau
[NE PAS TENIR COMPTE]
bureaux proche
bureaux à proximité
à proximité de bureau`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}