$re = '/(?<=\[)(.*?)(?=\])/m';
$str = 'Some line of text [185047078]1x some more text of - Type 1
[185047138]1x some other text of - Type 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);