package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[*]([a-z]|[A-Z]|[0-9]){3,}[*]$`)
var str = `*aaa**
*aaa*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}