$re = '/^[\d\w]{3}(?:[|][\d\w]{3}){0,2}$/m';
$str = 'abc|ghy|33d
abc|ghy
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);