import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(?:-[a-zA-Z]+)+\\K|\\G(?!^)-(\\d+)(?:(?:-[a-zA-Z]+)+|$)";
final String string = "accuracy-is-5\n"
+ "accuracy-is-5-or-15\n"
+ "accuracy-is-5-or-15-or-20\n"
+ "package-is-dip-8-or-dip-4-or-dip-16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}