import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(((?!\\}\\}).)*\\}*\\}*)\\}\\}";
final String string = "{{for(var i = 0; i < sites.length; i++) { const site = sites[i]; }}\n"
+ "<div class=\"panel panel-default\">\n"
+ " <div class=\"panel-heading\" role=\"tab\">\n"
+ " <h3 class=\"panel-title\">\n"
+ " <a href=\"#{{site.Nom}}\" onclick=\"event.preventDefault(); toggleOuvertureSite('{{site.Nom}}')\" role=\"button\">\n"
+ " {{site.Nom}} <span>({{site.Applications.length}})</span>\n"
+ " </a>\n"
+ " </h3>\n"
+ " </div>\n"
+ " <div class=\"panel-collapse collapse {{if(site.Ouvert){}}in{{}}}\" id=\"{{site.Nom}}\">\n"
+ " <div class=\"panel-body\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"col-md-6\">\n"
+ " <h4>Chemins virtuels</h4>\n"
+ " {{if(site.Applications.length == 0) {}}\n"
+ " <em>Aucun chemin virtuel</em>\n"
+ " {{} else {}}\n"
+ " {{for(var j = 0; j < site.Applications.length; j++) { const application = site.Applications[j]; }}\n"
+ " <div>{{application.CheminVirtuel}}</div>\n"
+ " {{}}}}\n"
+ " </div>\n"
+ " <div class=\"col-md-6\">\n"
+ " <h4>Liaisons</h4>\n"
+ " <table class=\"table table-condensed\">\n"
+ " {{for(var j = 0; j < site.Liaisons.length; j++) { const liaison = site.Liaisons[j]; }}\n"
+ " <tr class=\"row\">\n"
+ " <th class=\"col-xs-6\">{{liaison.Protocole}}</th>\n"
+ " <td class=\"col-xs-6\">{{liaison.Informations}}</td>\n"
+ " </tr>\n"
+ " {{}}}\n"
+ " </table>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ "</div>\n"
+ "{{}}}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}