re = /(\d{1,3}(?:\.\d{1,2}){0,1})?(km\/h|m\/h)?(?:(?:audi|bmw)(?:\scoupe)*)*/mi
str = '2.34 km/h
km/h 2.33'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end