// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img(?:[\s\w="]+)src="([^"]+)"(?:[\s\w="]*)\/?>"#).unwrap();
let string = "<img src=\"image1.jpg\" width=\"200\" height=\"200\">
<div>\\r\\n<h2 class=\\\"ng-binding\\\" style=\\\"text-align: center;\\\"><span style=\\\"color: #ff0000;\\\">قيولي50 درصدي دانش آموزان در آزمون تيزهوشان</span></h2>\\r\\n</div>\\r\\n<div class=\\\"ng-scope\\\" style=\\\"text-align: center;\\\">\\r\\n<div class=\\\"groupsRowSeperator\\\"> </div>\\r\\n<div id=\\\"contextData\\\">\\r\\n<h3 class=\\\"ng-scope\\\"><span style=\\\"color: #008000;\\\">افتخار آفريني تيزهوشاني </span></h3>\\r\\n<h3 class=\\\"ng-scope\\\"><span style=\\\"color: #800080;\\\">قبولي50 درصدي دانش آموزان دبستان هوشمند شهيد مهدوي در آزمون تيزهوشان سال تحصيلي 99-98 برگ زرين ديگري براي شما اولياي گرامي و همكاران محترم و نتيجه اطميناني بود كه به هم داشتيم.</span></h3>\\r\\n<h3 class=\\\"ng-scope\\\"><span style=\\\"color: #800080;\\\">اين موفقيت بزرگ را به كليه دانش آموزان عزيز ، والدين گرامي ، معلمين دلسوز ، همكاران پرتلاش دبستان هوشمند شهيد مهدوي تبريك و تهنيت عرض مي نمائيم.</span></h3>\\r\\n<p class=\\\"ng-scope\\\"> </p>\\r\\n<p class=\\\"ng-scope\\\"><img src=\\\"http://mahdavi-smart-school.ir/upload/5/akhbar/97-98/IMG-20190805-WA0014.jpg\\\" alt=\\\"\\\" width=\\\"423\\\" height=\\\"1060\\\" /></p>\\r\\n</div>\\r\\n</div>\\r\\n<div class=\\\"CommentBox\\\" style=\\\"text-align: center;\\\"> </div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}