re = /(<a(?:(?!\/a>).|\n)*(?=\>).)(.+)(<\/a>)/i
str = '<a href="http://">Text</a>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end