package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\d]\s-\s[a-z]`)
var str = `1 - hello`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}